How to Switch PHP Version

phpcPanel Hosting

GiraffeCloud supports PHP 5.2, 5.3, 5.4, 5 .5, 5.6 and 7.0 on its cPanel Hosting Servers, with PHP 5.4 being the default version.

If you had previously enabled a different PHP version using the older method of adding files named usealtphp, you need to make sure all these files have been deleted or renamed. You need to make sure that the following files do not exist:
/home/<username>/usealtphp
/home/<username>/usealtphp55
/opt/php52/<username>

1. Once this is confirmed, you can change the PHP version from cPanel itself now. You need to log into your cPanel and click on the option “Select PHP version”

cPanl

2. Once inside the selector menu, you need to select the PHP version you want to run on your website.

cPanl

3. Select the PHP modules you want to load and “Save” the modules and then making sure that the PHP version is a correct client on “Set as current” and this should make sure the chosen PHP version is set.

Plesk Hosting

By default, GiraffeCloud supports PHP 5.2 on its Plesk Hosting Servers. In order to switch to PHP 5.3, you need to make the following changes from the Plesk panel:

1. Login to the Plesk panel of the domain name for which you wish to switch the PHP version.

2. Click the Website & Domains tab and then the Show Advanced Options link.

Plesk

3. Here, click the Virtual Directories link.

Plesk

4. Under the Tools section, click the PHP Settings button.

Plesk

5. Select the 5.3.21 version and click the OK button.

Plesk

You may switch back to PHP 5.2 through the same process as mentioned above.